MT15 head and cab popping sound

Discussion in 'Amplifiers' started by Bucks, Jul 30, 2020.

  1. Bucks

    Bucks New Member

    Joined:
    Jul 21, 2020
    Messages:
    4
    Likes Received:
    0
    I recently purchased the MT15 lunchbox head and matching cab. About a week ago it started making a continuous popping sound when plugged in and nothing I’ve done stops it.

    Any advice is greatly appreciated.

    thanks
     
  2. JJJ

    JJJ asleep

    Joined:
    Mar 21, 2018
    Messages:
    369
    Likes Received:
    320
    Regular intervals or random? Low frequency? Hissing or rustling leaves with it? Popping can be a hundred things. You can try some simple stuff like rocking tubes, using some contact cleaner on the pins/sockets etc. Don't take this the wrong way, but from your question I gather you aren't used to working on tube amps and as such I'd say anything beyond some cleaner and trying different cables, I would take it to a tech for an appraisal. IME popping comes from dirty sockets or a bad tube.

    If the amp is new from a store however, none of this is your problem because it should have a warranty
     
    Deli6505 likes this.
  3. Deli6505

    Deli6505 Rockin' the D!

    Joined:
    Sep 6, 2014
    Messages:
    330
    Likes Received:
    506
    When I had a Dual Recto, popping was a result of bad pre-amp tubes. Luckily my MT15 has never given me any troubles but my Dual Rec was a gigantic pain in my a$$ every other week that needed constant baby-sitting. I would take your MT15 to a reputable technician and have him/her look it over.
     
    Bucks likes this.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice