Intermittent hum with new HDRX 20.

Maggot Brain

New Member
Joined
Nov 22, 2022
Messages
7
I'm just curious if anyone else has run into this issue with their HDRX 20?

I've been madly in love with amp so imagine my horror when I turned it on and got a loud 60hz hum coming from the speaker. The input doesn't affect it (still there with or without guitar plugged in) and non of the controls affect the hum. It cut in and out while touching the High Mid Gain switch but returned. I have temporarily alleviated it by cycling the power on and off, after 1 or 2 times or switching the amp on and off it goes back to early dead silence and performs perfectly. Tapping on the amp will make the hum cut in and out so I believe it maybe internal. I have checked all the tubes for microphonic, I've made sure they are all properly seated. I have confirmed the bias is within spec and the transformer is bolted up tight.

It was shipped via FedEx and may of got banged up in shipping. When it arrived I noticed the power tubes weren't completely seated... I really wished their was a PRS dealer closer to me!


I've owned it just over a week and pretty bummed but understand **** happens, if it weren't for bad luck I'd have no luck at all I'll be exchanging it for another HDRX20, just hope this isn't a common issue.
 

Rider1260

New Member
Joined
Jun 9, 2013
Messages
3,179
well you checked seating and microphonic tubes, sounds like a grounding issue on that switch you mentioned, seems like your handy it might be worth pulling it out of the cab and looking at that switch for loose grounding wires.
I would contact the dealer you got it from they will likely just send you a new amp I bet.
After Dealer contact PTC
 

Maggot Brain

New Member
Joined
Nov 22, 2022
Messages
7
well you checked seating and microphonic tubes, sounds like a grounding issue on that switch you mentioned, seems like your handy it might be worth pulling it out of the cab and looking at that switch for loose grounding wires.
I would contact the dealer you got it from they will likely just send you a new amp I bet.
After Dealer contact PTC
Thanks for the reply,
I think you're right as I just isolated it to the Mid High Gain switch. It has been acting up about every other power up and I can make it go away by flipping the MHG switch 2 or 3 times and also power it off and on 2 or 3 times.

Bummer as I love this amp so much but got a free gremlin included.

I won't have peace of mind until I exchange it for another one. I really wanna pull the chassis to to peak if it's something obvious but don't want to mess up the warrant.

Besides that, this is one of the greatest modern production amps I've ever played, wow! It's what I was hoping the SV20H would be.
 

Maggot Brain

New Member
Joined
Nov 22, 2022
Messages
7
Thanks!

Quick question, how long is PRS amplifier warranty? I've got the box and paperwork in the garage but have come down with a pretty bad flu (my excuse for a lazy question)

I'm just curious because after working the MHG switch and the Bright switch repeatedly it seems to be gone (knock on wood). I could get it to both act up and resolve by flipping the MHG switch but after doing that it's not doing it anymore. Maybe dust or debris in the switch? I'll still exchange it for another for the peace of mind but curious on whats going on (I'm an automotive technician so my curiosity to diag it is pretty strong haha)
 

Maggot Brain

New Member
Joined
Nov 22, 2022
Messages
7
Check the bias on the power tubes also check each preamp tube one by one
Yes, were some of the first things I checked. I pulled and reseated all tubes, checked for microphonic tubes, even swapped in known good tubes. Bias was within spec (26mv left power tube, 28mv right power tube) spec is between 25mv-30mv. Checked all connections, tried different outlets and even took it to a buddy's. I tried different cab and speakers etc...

but So far so good tho, working those switches may have resolved it. I figured out I could make it happen every time by flipping either switch but doesn't appear to be happening anymore. Hoping maybe just debris or a poor connection working the switch remedied. I'll reach out to PRS support and see what they suggest, I was pretty bummed as I've been pumped for this amp since it was announced (I'm a life long Hendrix geek) but feel relief knowing PRS has a 5 year warranty, that's great news. Sht happens so it's whatever, just funny because if it weren't for bad luck I'd have no luck at all!

Thanks guys ✌
 

Maggot Brain

New Member
Joined
Nov 22, 2022
Messages
7
Thanks for the replies!

I wanted to give a little update, unfortunately the hum has returned intermittently. I have isolated it to something internal in the amp. I've swapped tubes, checked bias, worked toggles back and fourth etc. It maybe in the circuit or a bad cap? It is affected by switching the Mid switch and Bright switch which I believe Paul said only switches caps in the circuit.

BUT I have been in such tonal nirvana with this amp and my 4x12 that I've been procrastinating getting it exchanged I need to get on it asap, I was really hoping it was just a fluke.

Besides this intermittent hum issue (I can still resolve it by powering off and on) I've just been so damn in love with this amp. I'm a huge Hendrix geek and have been chasing those tons since I first picked up a guitar and this damn near nails those Hendrix tones (paired with G12H 55hz) ... Phenomenal sounding amp. I find with the "High Mid gain" on it definitely captures his live '69+ tones and with it switched down/off you can get more earlier tones (1968ish) more like a traditional Superlead voicing.

I'll have to bite the bullet and get this dealt with, just having so much fun and so damn inspired to play hate to be without it for any period of time.
 

alantig

Zombie Four, DFZ
Joined
Apr 28, 2012
Messages
13,660
I'll have to bite the bullet and get this dealt with, just having so much fun and so damn inspired to play hate to be without it for any period of time.

Have you seen the thread about owning more than one?

a2eddd82-4b2c-4619-92d8-da0309401174_text.gif
 

Maggot Brain

New Member
Joined
Nov 22, 2022
Messages
7
Have you seen the thread about owning more than one?

a2eddd82-4b2c-4619-92d8-da0309401174_text.gif
100% have been considering buying a second hahaha so very funny post!

I legit don't want to spend a second without this amp. I can't say enough good things about this amazing amp! Just order another Scumback H55-PVC and Eminence Wizard to fill out my 4x12 for this baby.
 
Top