The MT15 rattle issue

Discussion in 'Amplifiers' started by Snowdogyyz, Dec 6, 2018.

  1. Snowdogyyz

    Snowdogyyz New Member

    Joined:
    Dec 6, 2018
    Messages:
    2
    Likes Received:
    0
    I’m new here but have been reading up on things for awhile. Just recently purchased the MT15 and love it- it’s a beast of an amp! However, I cannot seem to alleviate the chassis rattle I’m hearing which is highly annoying. I have tightened every screw, changed and re-seated tubes (sovteks), and put padded tape between the cover and chassis where it touches and the screws go in. Still rattles, especially when the clean boost is engaged. It’s sitting on top of my EVH 212 cab, but I have tried moving it beside the cab, putting a mat underneath, etc- still rattles. Any fixes I haven’t tried yet? The amp is amazing but this issue is highly annoying!
     
  2. LSchefman

    LSchefman Hears Tones

    Joined:
    Apr 26, 2012
    Messages:
    20,843
    Likes Received:
    10,791
    Consider the possibility that what you’re hearing is tube rattle. There’s another thread on this, but basically, the filaments and parts inside the tube rattle against the glass due to vibration.

    It’ll be a ringing sound if that’s the culprit. There are fixes.
     
    sergiodeblanc likes this.
  3. Snowdogyyz

    Snowdogyyz New Member

    Joined:
    Dec 6, 2018
    Messages:
    2
    Likes Received:
    0
    Thanks for the reply! It’s definitrky not tube rattle. I’ve dealt with that with other amps. This is a pronounced metal on metal vibration noise.
    To try something tonight, I took bubble packaging and placed a sheet under the amp on top of the cab- rattle disappeared! Now I have to find something better and more permanent to pad/isolate the amp and cab.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice