MT15 Driving me nuts

Discussion in 'Amplifiers' started by Rooster7six, Oct 25, 2018.

  1. Rooster7six

    Rooster7six New Member

    Joined:
    Sep 22, 2018
    Messages:
    27
    Likes Received:
    7
    Ok. So I have an MT15 and if I turn the volume to 8 o'clock or higher it has a really loud squeal while I'm pressing down on the strings. It does it on my fishman modern loaded guitar, an EMG loaded guitar, Nazgul loaded guitar . I have a Gibson V with a burstbucker 3 and it's not too bad and I have a JB loaded guitar that I potted myself that doesn't have a lot of noise. Today I bought a Mogami Gold cable and went straight into the amp. Still does it . I had put all tung-sol 12AX7's in the pre and a 12AT7 in the phase inverter. Pulled em all put the JJ's back in same ****. I have EHX EL34's in the power section but haven't messed with those yet . Any ideas?
     
  2. andy474x

    andy474x Knows the Drill

    Joined:
    May 4, 2012
    Messages:
    3,148
    Likes Received:
    1,407
    Happens only with a guitar plugged in? If so, it’s pickups feeding back, first things to do are move out of the direct path of your speakers, and/or reduce the amount of gain from the amp.
     
    ScottR and X-Mann like this.
  3. Rooster7six

    Rooster7six New Member

    Joined:
    Sep 22, 2018
    Messages:
    27
    Likes Received:
    7

    It's only when the guitars are plugged in .I'm plugged in with 18' of cable and as far away as possible, even went around the corner from my bedroom. The gain is around 11 o'clock, thats pretty low. I've had many amps, all high gain and never had this issue .
     
  4. Tone-y

    Tone-y New Member

    Joined:
    Jan 22, 2018
    Messages:
    232
    Likes Received:
    262
    Could it be a valve that's gone microphonic? As the EL34s are the only ones that you haven't swapped it sounds like the next task is to change those.
     
    Rooster7six likes this.
  5. Rooster7six

    Rooster7six New Member

    Joined:
    Sep 22, 2018
    Messages:
    27
    Likes Received:
    7
    For sure. I have a couple more and some 6l6's guess that will be the next step . But since it doesnt do it without a guitar plugged in i dunno. i wonder if something electronic could be causing it? Like a TV?
     
  6. bodia

    bodia Authorities said.....best leave it.....unsolved

    Joined:
    Jan 21, 2015
    Messages:
    13,008
    Likes Received:
    13,585
    How was it with the original power tubes? Did it just start after the EL34s were installed?
     
    Rooster7six and X-Mann like this.
  7. Tone-y

    Tone-y New Member

    Joined:
    Jan 22, 2018
    Messages:
    232
    Likes Received:
    262
    Buzz and hum caused by a TV or something else electrical, sure, but I've not come across squealing from that. Squealing suggests feedback/something microphonic and you seem to have ruled out pickups by using several guitars
     
    Rooster7six likes this.
  8. X-Mann

    X-Mann New Member

    Joined:
    Aug 31, 2018
    Messages:
    74
    Likes Received:
    100
    Side question:

    You can put EL34 power tubes in the MT15 amp?

    I did not realize this at all!

    I assume a full re-biasing needs to happen 1st. What does it change in sound & feel compared to the 6L6’s?

    I’m a fan of EL34 amps in general, but love the sound of the 6L6’s in this amp & wanted a different flavor overall.

    Thanks, X
     
  9. bodia

    bodia Authorities said.....best leave it.....unsolved

    Joined:
    Jan 21, 2015
    Messages:
    13,008
    Likes Received:
    13,585
    I am almost positive that someone on the forum reached out to Doug about this, and was told you could put EL34s in it. Bias was 30 +/- 5, iirc
     
    X-Mann likes this.
  10. X-Mann

    X-Mann New Member

    Joined:
    Aug 31, 2018
    Messages:
    74
    Likes Received:
    100
    This is a great question.

    Did ayou have the issue w/ the stock tunes & these guitars?

    Have you been playing the amp out or moving it around a lot?
     
    Rooster7six likes this.
  11. Rooster7six

    Rooster7six New Member

    Joined:
    Sep 22, 2018
    Messages:
    27
    Likes Received:
    7
    I don’t remember if I ever cranked it up. And then I moved it down into my master bedroom so there were a lot of changes in a short time.
     
  12. Rooster7six

    Rooster7six New Member

    Joined:
    Sep 22, 2018
    Messages:
    27
    Likes Received:
    7

    If you have a meter it takes one min! Super easy. The EL34’s sound great! I think you get a little more mids and growl. Still has plenty of low end.
     
  13. Rooster7six

    Rooster7six New Member

    Joined:
    Sep 22, 2018
    Messages:
    27
    Likes Received:
    7

    I’ve pretty much had it at home so far. There were no issues with the tubes I just think the Tung-Sols sound much better. Tried Russian JJ’s, EHX, and Sovtek LPS’s. Tung-Sols won out
     
  14. Rooster7six

    Rooster7six New Member

    Joined:
    Sep 22, 2018
    Messages:
    27
    Likes Received:
    7
    You can. I contacted PRS before I did it.
     
  15. vchizzle

    vchizzle Birdman.

    Joined:
    Apr 28, 2012
    Messages:
    6,361
    Likes Received:
    2,348
    I'd certainly start by going back to stock or at least different tubes and see what happens.
     
    Rooster7six likes this.
  16. Rooster7six

    Rooster7six New Member

    Joined:
    Sep 22, 2018
    Messages:
    27
    Likes Received:
    7
    I've put in all stock tubes, put in a different set of EL34's, stock 6l6's and finally Tung-sol 6l6GCSTR's and a different speaker cable. Not sure what else I can do.

    But I did discover that the Tung-sol 6l6's are my favorite. They make the amp sound meaner to me
     
  17. brokenromeo

    brokenromeo New Member

    Joined:
    Oct 10, 2018
    Messages:
    23
    Likes Received:
    25
    Sounds like your pickups/guitar is causing the squeal...super hot pickups and high gain levels/volume are going to cause squealing...make sure your pickups are securely mounted (so they can't vibrate) and you're probably going to have to lower the pickup height a bit if they are high output, and lower your gain settings. Tons of gain on tap with these amps...
     
    Rooster7six likes this.
  18. Rooster7six

    Rooster7six New Member

    Joined:
    Sep 22, 2018
    Messages:
    27
    Likes Received:
    7
    Yeah the Fishman moderns seem to be the worst. I just sold a dual rectifier multi-watt and had none if these issues . But i guess I didn't have to push the power section hard to get these same volumes . This amp probably is higher gain . I'll definitely try to lower the pups. Thanks for the advice!
     
  19. Rooster7six

    Rooster7six New Member

    Joined:
    Sep 22, 2018
    Messages:
    27
    Likes Received:
    7
    [​IMG] [​IMG]

    Gain settings... STILL squealing
     
  20. Rooster7six

    Rooster7six New Member

    Joined:
    Sep 22, 2018
    Messages:
    27
    Likes Received:
    7



    Squealing at very low gain
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice