Custom 50 Combo Presence/Depth problem

Discussion in 'Amplifiers' started by Base6, Dec 16, 2016.

  1. Base6

    Base6 Guitar Addict

    Joined:
    Aug 21, 2012
    Messages:
    61
    Likes Received:
    30
    For all you fellow Custom 50 users, do you also experience a "plop" when you pull the presence knob for the depth control? Is that normal?

    I checked all the connections, but they look fine.
     
  2. DreamTheaterRules

    DreamTheaterRules Navin R. Johnson

    Joined:
    Nov 20, 2013
    Messages:
    6,337
    Likes Received:
    10,103
    No, not on mine.
     
  3. cmedcoff

    cmedcoff New Member

    Joined:
    Jun 28, 2013
    Messages:
    63
    Likes Received:
    4
    Yes, I hear it on my 2-channel custom 20 head. Even a low volume. Makes me afraid to make a change if I've got it cranked.
     
  4. Rider1260

    Rider1260 New Member

    Joined:
    Jun 9, 2013
    Messages:
    2,513
    Likes Received:
    3,312
    Yes there is a POP when changing between Presences and Depth ( mine is a Modded 2 Channel H )
     
  5. DreamTheaterRules

    DreamTheaterRules Navin R. Johnson

    Joined:
    Nov 20, 2013
    Messages:
    6,337
    Likes Received:
    10,103
    Ok, checked mine again. It does have a minor pop. I don't turn it on and off enough to even remember that, and it's minor.
     
  6. Base6

    Base6 Guitar Addict

    Joined:
    Aug 21, 2012
    Messages:
    61
    Likes Received:
    30
    Thanks guys. I guess it is normal then.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice