Angelus AX20E buzzing alot

Discussion in 'Acoustic Guitars' started by Alessandro, Oct 26, 2018.

  1. Alessandro

    Alessandro New Member

    Joined:
    Jul 30, 2018
    Messages:
    14
    Likes Received:
    0
    I'm 100% certain its coming from the thumb wheel setup in the sound hole. If I put pressure on the unit and strum no issues at all but once I let go I can hear the buzzing distinctly and my heart has completely shattered. This was such a beauty and is only 3 months old and I shutter to think of the hoops I'm going t have to jump through now.

    I regrettably bought the guitar off amazon after finding out my local dealer would probably take months to fill an order through them. I've contacted amazon and they are offering refund to ship it back but before I go down the hail Mary route of getting a refund through amazon I'm wondering if any other Angelus players have experienced this issue and have any tips on how to resolve it so I wont have to send it in.

    Thanks in advance
     
  2. AP515

    AP515 Mostly Normal

    Joined:
    Apr 26, 2012
    Messages:
    2,571
    Likes Received:
    1,375
    If I understand your description, you are touching the electronics for the electric pickup. Just a guess but it may be that the battery compartment has come loose. Might be worth removing the strings and getting in there and seeing what is going on. Might need to tighten things up in there.
     
  3. Alessandro

    Alessandro New Member

    Joined:
    Jul 30, 2018
    Messages:
    14
    Likes Received:
    0
    Thanks for the response. The batter is actually in another compartment on the side of the guitar. It’s definitely the electronics for the pickup. I believe it’s the the thumb wheels that are actually vibrating when I strum. Are you an angelus owner? Ever had this issue?
     
  4. Rider1260

    Rider1260 New Member

    Joined:
    Jun 9, 2013
    Messages:
    1,921
    Likes Received:
    1,735
    I would contact PTC they are great to deal with and will get you right
     
  5. AP515

    AP515 Mostly Normal

    Joined:
    Apr 26, 2012
    Messages:
    2,571
    Likes Received:
    1,375
    I do own an Angelus but mine is a Gen 1 and the electronics are all on the side. Nothing in the sound hole. I would still inspect the body holding the wheels and see if the cause is obvious. IF not as Rider says, contact PRS. They may have seen this before.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice